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Web Services


Web Services Using .NET

Operating Systems CS 370

Text:  

http://quickstarts.asp.net/QuickStartv20/default.aspx 
http://samples.gotdotnet.com/quickstart/aspplus/ 

Objectives:

During this class the student shall learn to:

· Describe issues that should be considered when implementing a client-server interface, related to intelligence distribution.

· Describe why platform independence is important, and why a standard protocol interface is beneficial.

· Describe the main differences between web forms and web services, and when each may be used.

· Define UDDI, WSDL, XML, HTTP, SOAP.
· Draw an architecture for the .NET client-server interface, showing where or how UDDI, WSDL, XML, HTTP, SOAP exists or is used.

· Discuss the main function of the HTTP protocol.

· Read HTML and XML data.
· Develop a windows client application to interface with a IIS .NET server.

Time Allocation:

Class time will be allocated as follows:


Intro & Architecture



½ hour

HTTP/SOAP Protocol


½ hour


WSDL/XML




½ hour


In-class Lab




1 hour

TOTAL:




2.5 hours

Distributed Applications
Intelligence Distribution:  Where should most processing be performed?

· Browser-Based Clients:  Most code is executed at server
· Browsers contain forms and little else

· Good for simple and diverse clients but processing must occur at server side

· Problem:  The server can become a bottleneck

· E.g., CGI, ASP.NET web  site, HTTP servlet
· Smart Clients:  Much code is executed at Client
· Clients have substantial logic but require access to common database

· Offloads processing to client but requires more than a simple browser

· E.g., ASP.NET web services, Java applet
· How do we distribute (download) this intelligence?

· Client-resident:  Client code is located on client machine

· E.g., ASP.NET Web Services
· Client-downloaded:  Client code is downloaded from the server

· E.g., Java applet, Java RMI (optional), html-based solutions, ASP.NET Web forms, ActiveX 
Platform-Independence:  Prefer that the client and server do NOT have to be coded in the same language.

· Java RMI, Java applet:  Client & Server must both be in Java

· ASP.NET web form or web services:  Client and server can be programmed in different languages

· J#, C#, Visual Basic, or C++


Protocol Interface:  Must be standard, defined, upgradeable.

· Java RMI, Java applet:  Based on Java standard.

· ASP.NET web forms:  Uses HTML & HTTP standard web protocols.

· ASP.NET web services:  
· XML is a standard protocol for defining metadata.
· HTTP or SOAP contains the request/response structure

· WSDL defines application.

Main Use:  B2B or C2B?
Web Form = Customer-to-Business (C2B):  Public manual interface accessible by web page
· Build a web page for customers to download (HTML/HTTP)

· Customers use any browser to access web page interface.

Web Service = Business-to-Business (B2B):  Automated Interface between two programs

· Define an interface to the world and publish the server (WSDL, XML)
· Companies program the interface and distribute the client

· Automated interface allows clients to access server via well-defined interface.

Three-Tier Architecture for .NET
Web Forms
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Web Services
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· Client Tier:  User Interface

· Middle Tier: Business or control logic

· Information Tier = Data Tier:  Data access and maintenance

Protocol Implementation: Web Forms versus Web Services

Definitions
· IIS: Microsoft Internet Information Services: Web server

· HTML: HyperText Markup Language

· MIME: Multipurpose Internet Mail Extensions: Describes data format

URL:  Uniform Resource Locator ASP.NET Web Forms


Client





Server


HTML URL req.--------------------------(


(-------------------------------------  HTML Form


HTTP Response---------------------------( Processing .aspx.cs



(-------------------------------------- HTTP/HTML Data
Web Form:

Client downloads a form, fills it in, and sends to server
Web Form HTML Example (Simplified)

<%@ Page Language="C#" AutoEventWireup="true"  CodeFile="Default.aspx.cs" Inherits="_Default" %>

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" >

<head runat="server">

    <title>Registration Form</title>

</head>

<body>

    <form id="form1" runat="server">

    <div>
        <asp:TextBox ID="CommandTextBox" runat="server" </asp:TextBox>

        <asp:Button ID="SubmitButton" runat="server" 
           OnClick="GetButton_Click" Text="Submit" />

        <asp:Label ID="HelpLabel" runat="server" Text="Enter command 
           and Press Submit " </asp:Label>
    </div>

    </form>

</body>

</html>

Note: The ‘runat=server’ indicates that all processing happens at the server.  The form is entered at the client side.
HTTP Protocol

HTTP: HyperText Transfer Protocol

· Connection-oriented: Uses TCP

· Stateless: Server keeps no information about the client

· Text-based: All messages are readable
Client (Web Browser):  ------Request--------------(
(------Reply------------------
Web Server

HTTP Client Request:

Request Line: 

Format: <CMD> <URI> <Protocol> \r\n

Example: POST/examples  HTTP/1.1

Example SOAP: POST /Chemistry/BestWebService.asmx HTTP/1.1

<CMD>:  Command to be performed:

· GET: Retrieve contents of a web object at URI

· PUT: Store request to the specified URI

· HEAD: Retrieve header (not object) from the server

· POST: Send data to a server process

<URI>: Uniform Resource Identifier: Specifies a file to open
· /directoryPath/…/directoryPath/file

· Optional: index.html assumed if not specified

<Protocol>: Application layer protocol/version = e.g., HTTP/1.1

Web Forms can use SOAP or HTTP GET or HTTP PUT.  SOAP must be used with structures or classes.

Request Header:

Format: <keyword>: <value>\r\n

Example: 

User-Agent: Generic



Type of browser

Host:localhost:81




Name of the server 

Content-type: text/xml;charset=utf-8   
Where utf=Unicode

Content-length:470



Number of bytes in Body

Request Body:

Contains a blank line before the body

Body contains data to be transferred: SOAP protocol

SOAPAction:”/examples”



<?xml version="1.0" encoding="utf-8"?>


<SOAP-ENV:Envelope SOAP-ENV:encodingStyle=”http://schemas.xmlsoap.org /soap/encoding/”

xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/" 
…

<SOAP-ENV:Body>

   <m:getChemicalName  xmlns:m=http://www.soapware.org/”> 

      <chemnum xsi:type=”xsd:int”26</chemnum>    

   </m:getChemicalName >

</SOAP-ENV:Body>

</SOAP-ENV:Envelope>

Above:

· Object = /Examples

· Method = getChemicalName(int chemnum=26)

UTF-8 = Unicode-8
HTTP Server Response:

Status Line:

Format: <Protocol>  <Status-Code>  <Description>

Example:  HTTP/1.1   404   Not found

<Protocol>: E.g., HTTP/1.1

<Status-Code>

· 100-199 Informational

· 200-299 Client request successful

· 300-399 Client request redirected

· 400-499 Client request incomplete

· 500-599 Server errors

<Description>: Text: e.g. OK; NOT FOUND

Example: SOAP Response:

HTTP/1.1 200 OK

Connection: close

Content-Length: 491

Content-Type: text/xml; charset=utf-8

Date: Mon, 23 Apr 2004  04:03:30 GMT

….

   <SOAP-ENV:Body>

      <m:getChemNameResponse xmlns:m=http://www.soapware.org/>

         <Result xsi:type=”xsd:string”> Iron</Result>

      </m:getChemNameResponse>

   </SOAP-ENV:Body>

…

Above examples are adapted from: Distributed Computing Principles and Applications, M L Liu, Addison Wesley, 2003.  Notation may be specific to Apache SOAP API.
ASP.NET Web Service


Client





Server


Get Interface: Access WSDL describing interface



(-----------------------------------------
WSDL accessed via HTML


Program interface, install on client


HTTP/SOAP request-------------------------( Processing aspmx.cs


HTTP/SOAP reply(---------------------------

Web Services provide:

· A registry where services can be advertised, called a Universal Discovery Description and Integration (UDDI)

· A detailed description of how a client can connect to a server (via a ‘WSDL’ document)

· Standard protocols in which to access the web services, including SOAP, which uses XML, and HTTP.

· A simple method to program GUI

Advantages:

· Client and Server can be written in different programming languages (J#, VB, C#, C++)

· Uses standard protocols supported by most operating systems: HTTP, TCP/IP

· SOAP is simple to implement (but offers few features)

Web Services

Web Services Architecture for the Client
Remote Procedure Call:  Transmission using TCP/IP is performed as a function or method call.

Proxy:  Converts requests from the application client into properly-formatted SOAP calls based upon WSDL
· Web Service Description Language (WSDL): Describes how to use a web service
· Describes methods and parameters in XML
· File is retrieved from web service in order to create the Proxy

· Simple Object Access Protocol (SOAP): Execute web services using XML and HTTP (GET, PUT) protocols.

Client Class: Supports programmer-defined code containing GUI
· .aspx: Details of visual aspect of web form

· .aspx.vb: The ‘code-behind’ the .aspx file: What happens when button is pushed?

· form1.vb: In Windows.NET equivalent to .aspx.vb. (No .aspx file exists)
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Universal Discovery Description and Integration (UDDI)

· Service Registration

· White pages: Describe the company offering the service: name, address, contacts, etc.

· Yellow Pages: Categorizes services based on standard taxonomies.  Other search techniques include by company, by region.

· Green Pages: Describe the interface to the service (often WSDL)

· Free to publish and inquire about web services

Examples of UDDIs:

http://www.xmethods.com  http://uddi.microsoft.com 

http://www-3.ibm.com/services/uddi http://www.systinet.com/web/uddi 

Web Service Client/Server Protocol
	L2 Hdr
	IP
	TCP
	HTTP
	SOAP

(XML)
	L2 Checkcode


XML – Extensible Markup Language

XML is based on HTML (HyperText Markup Language)

· Open technology (non-proprietary)

· Data Description Language

· Schema: Validation format for an XML document

XML Formatting:

<!—This is a comment -->

<Tag>  element </Tag>

Example: <firstName> John </firstName>

Example Empty Element: 
<flag gender=”F” /> or 

<flag gender = “F”></flag>

Protocols that use XML:

· WSDL: Web Services Description Language: Describes the web service

· SOAP: Simple Object Access Protocol: Uses (or provides) the web service
WSDL: Web Services Description Language

· Describes how to use a web service

· Describes methods and parameters

· Written in XML

Here is a copy of part of a WSDL file (uses XML):

<?xml version="1.0" encoding="utf-8"?>

<wsdl:definitions xmlns:http="http://schemas.xmlsoap.org/wsdl/http/" xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/" xmlns:s="http://www.w3.org/2001/XMLSchema" xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/" xmlns:tns="http://sayings.jacomac.de" xmlns:tm="http://microsoft.com/wsdl/mime/textMatching/" xmlns:mime="http://schemas.xmlsoap.org/wsdl/mime/" targetNamespace="http://sayings.jacomac.de" xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/">

Type– Defines data types. Refers to a type system (such as XSD). 

· element. Refers to an XSD element using a QName. 

  <wsdl:types>

    <s:schema elementFormDefault="qualified" 
targetNamespace="http://sayings.jacomac.de">

      <s:complexType name="Saying">

        <s:complexContent mixed="false">

          <s:extension base="tns:SayingCore">

            <s:sequence>

              <s:element minOccurs="1" maxOccurs="1" name="id" 
type="s:int" />

              <s:element minOccurs="0" maxOccurs="1" 
name="relatedSayings" type="tns:ArrayOfInt" />

            </s:sequence>

          </s:extension>

        </s:complexContent>

      </s:complexType>

      <s:complexType name="SayingCore">

        <s:sequence>

          <s:element minOccurs="0" maxOccurs="1" name="sayingText" 
type="s:string" />

          <s:element minOccurs="0" maxOccurs="1" 
name="literalTranslation" type="s:string" />

          <s:element minOccurs="0" maxOccurs="1" 
name="languageOfSaying" type="s:string" />

          <s:element minOccurs="0" maxOccurs="1" 
name="meaningInEnglish" type="s:string" />

        </s:sequence>

      </s:complexType>

      <s:element name="searchForSayingsUsingLanguageName">

        <s:complexType>

          <s:sequence>

            <s:element minOccurs="0" maxOccurs="1" name="searchString" 
type="s:string" />

            <s:element minOccurs="0" maxOccurs="1" name="languageType" 
type="s:string" />

          </s:sequence>

        </s:complexType>

      </s:element>

      <s:element name="searchForSayingsUsingLanguageNameResponse">

        <s:complexType>

          <s:sequence>

            <s:element minOccurs="0" maxOccurs="1" 
name="searchForSayingsUsingLanguageNameResult" 
type="tns:ArrayOfSaying" />

          </s:sequence>

        </s:complexType>

      <s:complexType name="ArrayOfSaying">

        <s:sequence>

          <s:element minOccurs="0" maxOccurs="unbounded" name="Saying" 
nillable="true" type="tns:Saying" />

        </s:sequence>

      </s:complexType>

      </s:element>
Message– Defines the request and response messages for a web method.
  <wsdl:message name="searchForSayingsUsingLanguageNameSoapIn">

    <wsdl:part name="parameters" 
element="tns:searchForSayingsUsingLanguageName" />

  </wsdl:message>

  <wsdl:message name="searchForSayingsUsingLanguageNameSoapOut">

    <wsdl:part name="parameters" 
element="tns:searchForSayingsUsingLanguageNameResponse" />

  </wsdl:message>
Port Type- Defines the set of operations. Each Operation refers to an input message and output messages according to a type: HTTP Get, HTTP Put, and SOAP
  <wsdl:portType name="serviceSoap">

    <wsdl:operation name="searchForSayingsUsingLanguageName">

      <documentation xmlns="http://schemas.xmlsoap.org/wsdl/">This let's you look for sayings in the DB. Use the name of a European language with this method. Use 'any' if you don't want to limit your search to just one language.</documentation>

      <wsdl:input message="tns:searchForSayingsUsingLanguageNameSoapIn" />

      <wsdl:output 
message="tns:searchForSayingsUsingLanguageNameSoapOut" />

    </wsdl:operation>

  </wsdl:portType>
Binding– Defines the concrete protocol and data format specification for the operations and messages defined by a particular port type (using SOAP, HTTP Get, or HTTP Put). 

  <wsdl:binding name="serviceSoap" type="tns:serviceSoap">

    <soap:binding transport="http://schemas.xmlsoap.org/soap/http" 
style="document" />

    <wsdl:operation name="searchForSayingsUsingLanguageName">

      <soap:operation soapAction="http://sayings.jacomac.de/searchForSayingsUsingLanguageName" style="document" />

      <wsdl:input>

        <soap:body use="literal" />

      </wsdl:input>

      <wsdl:output>

        <soap:body use="literal" />

      </wsdl:output>

    </wsdl:operation>

  </wsdl:binding>
Service–Specifies characteristics of the web service itself (e.g., the URL). 

  <wsdl:service name="service">

    <documentation xmlns="http://schemas.xmlsoap.org/wsdl/">A collection of European proverbs, sayings and idiomatic expressions, reference langauge is English. Special European characters are and have been converted into html entities using the a unicode charmap.</documentation>

    <wsdl:port name="serviceSoap" binding="tns:serviceSoap">

      <soap:address location="http://dotnet.rus.uni-
stuttgart.de/ws_konrad/sayings/service.asmx" />

    </wsdl:port>

  </wsdl:service>

</wsdl:definitions>

What is the full signature for: searchForSayingsUsingLanguageName()?
Windows.NET Web Service Code 

We will review this code contained in Form1.cs (C#):

using System;

using System.Drawing;

using System.Collections;

using System.ComponentModel;

using System.Windows.Forms;

using System.Data;

using SueProject.de.uni_stuttgart.rus.dotnet;  // added

namespace WindowsApplication1

{


/// <summary>


/// Summary description for Form1.


/// </summary>


public class Form1 : System.Windows.Forms.Form


{



private System.Windows.Forms.Label label1;



private System.Windows.Forms.TextBox textBox1;



private System.Windows.Forms.Button button1;



private System.Windows.Forms.TextBox textBox2;



private System.Windows.Forms.TextBox textBox3;



/// <summary>



/// Required designer variable.



/// </summary>



private System.ComponentModel.Container components = null;



public Form1()



{




//




// Required for Windows Form Designer support




//




InitializeComponent();




//




// TODO: Add any constructor code after 

// 
InitializeComponent call




//



}



/// <summary>



/// Clean up any resources being used.



/// </summary>



protected override void Dispose( bool disposing )



{




if( disposing )




{





if (components != null) 





{






components.Dispose();





}




}




base.Dispose( disposing );



}



#region Windows Form Designer generated code



/// <summary>



/// Required method for Designer support - do not modify



/// the contents of this method with the code editor.



/// </summary>



private void InitializeComponent()



{




this.label1 = new System.Windows.Forms.Label();




this.textBox1 = new System.Windows.Forms.TextBox();




this.button1 = new System.Windows.Forms.Button();




this.textBox2 = new System.Windows.Forms.TextBox();




this.textBox3 = new System.Windows.Forms.TextBox();




this.SuspendLayout();




// 




// label1




// 




this.label1.Location = new System.Drawing.Point(

32, 40);




this.label1.Name = "label1";




this.label1.TabIndex = 0;




this.label1.Text = "Language";




// 




// textBox1




// 




this.textBox1.Location = new 

System.Drawing.Point(168, 40);




this.textBox1.Name = "textBox1";




this.textBox1.TabIndex = 1;




this.textBox1.Text = "";




// 




// button1




// 




this.button1.Location = new System.Drawing.Point(

88, 192);




this.button1.Name = "button1";




this.button1.TabIndex = 2;




this.button1.Text = "Get Saying";




this.button1.Click += new 

System.EventHandler(this.button1_Click);




// 




// textBox2




// 




this.textBox2.Location = new System.Drawing.Point(

8, 120);




this.textBox2.Name = "textBox2";




this.textBox2.Size = new System.Drawing.Size(

832, 20);




this.textBox2.TabIndex = 3;




this.textBox2.Text = "";




// 




// textBox3




// 




this.textBox3.Location = new System.Drawing.Point(

8, 88);




this.textBox3.Name = "textBox3";




this.textBox3.Size = new System.Drawing.Size(

832, 20);




this.textBox3.TabIndex = 4;




this.textBox3.Text = "";




// 




// Form1




// 




this.AutoScaleBaseSize = new System.Drawing.Size(

5, 13);




this.ClientSize = new System.Drawing.Size(880, 266);




this.Controls.Add(this.textBox3);




this.Controls.Add(this.textBox2);




this.Controls.Add(this.button1);




this.Controls.Add(this.textBox1);




this.Controls.Add(this.label1);




this.Name = "Form1";




this.Text = "Form1";




this.Load += new 

System.EventHandler(this.Form1_Load);




this.ResumeLayout(false);



}



#endregion



/// <summary>



/// The main entry point for the application.



/// </summary>



[STAThread]



static void Main() 



{




Application.Run(new Form1());



}



private void Form1_Load(object sender, System.EventArgs e)



{



}



private void button1_Click(object sender, 

System.EventArgs e)



{




// This code was added




SueProject.de.uni_stuttgart.rus.dotnet.service t =





new 

SueProject.de.uni_stuttgart.rus.dotnet.service();




SueProject.de.uni_stuttgart.rus.dotnet.Saying [] 

sayings =

t.searchForSayingsUsingLanguageName("",

textBox1.Text);




Random r = new Random();




int index = r.Next(sayings.Length);




textBox2.Text = sayings[index].meaningInEnglish;




textBox3.Text = sayings[index].literalTranslation;



}


}

}

Note: In J# it is not possible to access textBoxN directly.  Instead use getters and setters:


this.textBox1.set_Text(…);


this.textBox2.get_Text();
MS Windows Lab – Web Services
Select Start->Microsoft Visual Studio .NET 2005

Select File-> New-> Project


Select project type: Visual C# 

Select Windows Application


Enter Name: GetCurrency

The form window comes up


In left window click on References


Right click and select “Add Web Reference”

In the “Add Web Reference” window:

Set URL to: www.xmethods.com

Select “Go”

In the www.xmethods.com window


Select extended list: 



Try It 

Currency Exchange Service

Select the Currency Exchange Service link.

In XMethods Currency Exchange Rate page


Click on the “WSDL” link


Then select “Add Reference”

In the Form:


Find “Web References” in left box.

Double click on link to com.freewebs.www 

Expand (+) in “Object” box references for 

GetCurrency.com.freewebs.www

Click on Currency Exchange Service to show available functions.

We will use getRate(string, string))


Hold cursor over red diamond of getRate() to see full signature: 


   public System.Single getRate(System.String country1, System.String country2)


Click on Form1.cs [Design] tab

Create your form by:  (If toolbox is not available select View-> Toolbox)

Add Country 1 and Country 2 Labels:



Click on label and add label to form


Type “Country 1” (should change Text box) and relabel your label.



Create another label and name it “Country 2”


Click and add a small “TextBox” to form, next to the “Country 1” label



This textBox1 is where the user is expected to enter text for country 1.



Backspace for null data in textBox1



Create another TextBox for Country 2 next to the Country 2 label.


Click and add a button to form.



Label the button “Find Rate”


Click and add a longer TextBox to form, below the button.



This textBox2 is where the response will display.



Backspace for null data in textBox2.


Once your form looks good, double click the “Find Rate” button

You are now modifying the button1_Click() function


Type com.


The system should prompt you for the next field


Continue typing: 



com.freewebs.www.CurrencyExchangeService c = 

new com.freewebs.www.CurrencyExchangeService();



// Signature is Single getRate(string country1, string country2)



Single currency = c.getRate(textBox1.Text, textBox2.Text);


textBox3.Text=currency.ToString();

At dropdown menu click:


Build->Build Solution


Debug->Start


Country 1: United States

Country 2: Canada


Exchange Rate should display.

Lab: Creating a Windows.NET client application

· Go to UDDI at:  http://www.xmethods.com  

· Select “Full Service List”

· Select Temperature Convert (about 1 page down in Full Service List)

· Implement a program that converts from Celsius to Fahrenheit and from Fahrenheit to Celsius.  There should be two buttons: To Fahrenheit and To Celsius

(This is similar to my example in the notes above.)

Get Names Service

Show the instructor when you are done.

Select Start->Microsoft Visual Studio .NET 2005


Select File-> New-> Project


Select project type: Visual C# 


Select Windows Application


Enter Name: GetNames

The form window comes up


In left window click on References


Right click and select “Add Web Reference”

In the “Add Web Reference” window:


Set URL to: www.xmethods.com

Select “Go”

In the www.xmethods.com window



Try It 

Name and Gender

Select the Names and Gender link.

In XMethods Currency Exchange Rate page


Click on the “WSDL” link


Then select “Add Reference”

In the Form:


Find “Web References” in right box.

Double click on link to com.thomas-bayer.www 


Expand (+) in “Object” box references for 

GetNames.com.thomas-bayer.www


Click on Names Service Service to show available functions.

We will use getCountries() and getNamesInCountry()


Hold cursor over red diamond of getNames() to see full signature: 


   public String[] getNames()


Click on Form1.cs [Design] tab

Create your form by:  (If toolbox is not available select View-> Toolbox)


Add ‘Get Countries’ and ‘Get Names in Country’ Buttons:



Click on button and add button to form



Type “Get Countries” to change button name.



Create another button and name it “Get Names in Country”


Click and add a long “TextBox” to form, below the buttons



This textBox1 is where the output will be printed.



Backspace for null data in textBox1


Once your form looks good, double click the “Get Countries” button


Add new private class attributes for the form:

Type com.



The system should prompt you for the next field



Continue typing to create an object accessible to all functions:



com.thomas_bayer.www.NamesServiceService n;



Also add attribute:



String country = “England”;


In the form constructor, allocate the new web service object:

n = new com.thomas_bayer.www.NamesServiceService();


Complete the Get Countries button logic by creating a string for a country:

            string[] stringout = n.getCountries();

            if (stringout == null)

            {

                textBox1.Text = "No Reply";

                return;

            }

            Random r = new Random();

            int index = r.Next(stringout.Length); 

            if (stringout[index] == null)

                textBox1.Text = "No Reply";

            else

            {

                textBox1.Text = stringout[index];

                country = stringout[index];

            }


Go back to Form1.cs [design] and double click on the other button (Get names in Country):

            string[] stringout = n.getNamesInCountry(country);

            String namesString = " ";

            if (stringout == null)

            {

                textBox1.Text = "No Reply";

                return;

            }

            for (int i = 0; i < stringout.Length; i++)

            {

                if (stringout[i] == null)

                    textBox1.Text = "No Entry";

                else

                  namesString += stringout[i] + ", ";

            }

            textBox1.Text = namesString;

        }

At dropdown menu click:


Build->Build Solution


Debug->Start


Select Get Countries


Select Get Names in Country

Middle
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